Kogence Forum

Jump to: navigation, search

About this board

By clicking "Add topic", you agree to the terms of use for this wiki.
Vkonstantinov (talkcontribs)

Good evening!

Is there any way to pay for the subscription without using the Stipe platfrom?

I am from Russia and the Stripe does not allow to use Russian bank card

Mukul (talkcontribs)

@Vkonstantinov, thanks for reaching out. Yes we support other payment channels. Could you send an email to support@kogence.com? They will send you other payment links that would work for you.

AhsanMahmood (talkcontribs)

how do i select a software to run the code. I want to use Matlab

Mukul (talkcontribs)

@AhsanMahmood, have you signed up for Serviced Team Plan? Commercial software access requires Team Plan.

Robz (talkcontribs)

This is the same person trying Chrome

Same problem

I see an input file

...and a "+" I guess to enter an other input file


OK....I will look for one

Can I delete this model?

Didn't want to have clutter in My Models if I can't use it


I am trying another example. Will it tell me when the job is running as it's at the point which says starting instance for running job

About how long with that take?

LAMMPS model of a 3D polymer Test

About how long will I have to wait to visualize?

Never mind...it is active now

Didn't seem to work too well

It told me the visualizer was active and I clicked on it. I got two small screens with status of what was happening then finally a message starting visualization. Then it went back to my user page. Move the mouse over visualize again and it won't let me

Never saw the visualization.

I didn't get to see anything

I though this was a graphical component

I have to leave. Thanks for your help.

Centaure99 (talkcontribs)


OK. Can you go to "Software" subtab and let me know what you see there?

What software are selected in the dropdown menu?

OH, that is the problem. As I told you commercial software need license to be associated.

You can try using some opensource software if you like to test the platform.

For example, you can try Octave, GAMESS, Quantum Espresso etc. There are many available.

No I cannot. But dont worry no one else can see it. You can just make it private in the "Collaborate" tab.

I am sorry, that is also part of paid account feature.

Please try using platform and make sure it solves your technical needs.

Once you think there is a value, you can upgrade to paid account for better feature set.

All you need to do is to go to My Teams page and purchase a team subscription.

Or if you are an enterprise user, you can upgrade to enterprise. That is our higest service level with full capabilities and white glove treatment!

Is there anything else I can help you with?

Yes, its will say "Visualizer is live".

If this is a job that has some graphical components then those graphical components will open inside the Visualizer tab on top right corner.

If it is just a batch script then it will execute and exit. Log files will be under "Files" tab. You can still click the "Visualizer" tab and you can see progress there.

About 2mins.

By the way, if you stop and then make some edits and restart simulation then there will be no wait and it will come right away.

This means that simulation ended. It was not configured to hold the machine. By default platform is setup to automatically terminate machine when simulation ends.

You can go to "Files" tab and you will see log files that will show that it completed. All results will also be there.

If I like to hold the machine, you can do that as wll.

There are many ways to do that.

You just need to open a graphical component that will hold the machine until you close the graphical component.

Here is an easy way to do that.

Go to "Software" tab. Click "+" button. Add add a software called "xterm" or "gnome terminal".

Then machine will not terminate automatically because xterm never terminates until you close it manually.

Sure. Thanks for trying Kogence.

Feel free to ping us again if you need further assistance.

Robz (talkcontribs)

Do I only have access to run 4 models with a free account?

I only see 4 examples

Just browsing. It seems you have about 30 to 40 applications available. Is that correct?

Do any of the 40 applications require a license or are they all open source?

Again, just browsing


I can't seem to run a job which I copied.

It tells me to copy it

Yes...I am in My Models and I see the model I copied. Tried to run it and it doesn't allow me.

To run a simulation, copy/fork the model

I am in Settings and on the Machine subtab.

It doesn't allow me to select run on autoscaling cluster which, I have 4 cpus selected

I would like to get it running on my screen to see how easy the platform is to use

Are you talking about cores?

I can't check that box and no I can't run a job

Yes, and I put test at the end of the old name. That is the model I found in my models

Simulation account details

Run time is 1

Different CPU configs which 2 CPUs selected and saved in the machine details box

Run on autoscaling cluster is grayed out

Because I am not paying

Nothing under GPUs

Yes and it says Enter run time (hours) and it's set to 1

Doesn't let me use the dropdown menu

Ok...will I lose this chat?

Yes....That is the name I gave it and it still does not work now that I logged back in.

It's in my models so I should be able to run it



I have Chrome

Centaure99 (talkcontribs)

No. You can run as many as you like.

Oh, those are just getting-started templates to make life easier.

You can click on "Models" tab to search and explore our entire model library.

You can fork any of those models.

You can also create your own models.

May know which applications are you interested in so that I can guide you more appropriately.

That is right. Those 40 are available pre configured. You can also bring your own applications to platform. Or you can request us to configure if you like.

Some do. All commercial software require a license to be associated with your account on kogence.

Is there a specific one you are interested in?

Sure, no problem.

I am here to assist. Feel free to use this Live Chat or Forum to ask any question you might have. I might not be the person, but someone will answer.

If you put specific application details then person who will respond will be the area expert.

Are you logged-in?

What message do you see?

Can you go to "Settings" tab and make sure there is a Compute Plan selected under "Machine" subtab and also some software is selected under "Software" tab.

I can take a quick look. Can you go to "Collaborate" tab and add support@kogence.com as an admin. I will fix it right away.

I see. Auto-scaling cluster feature is available only under paid account.

You can run on any type of single machine with free account. We have pretty powerful single machines with upto 128cpu on single node.


Are you able to run on single node? Dont checkmark the autoscaling box.

When you copied the model, did it ask you to give it a new name?

OK. Can you do me a favor. Can you go to "Settings" tab and then "Machine" sub tab and let me know what you see there?

So under he Simulation account details, do you see a dropdown box that says "Compute Plan" ?

Yes, about that text box there is a dropdown menu. Is something selected in that dropdown menu?

*above that text box

Hmmm. Can you logout and log back in. Seems like your browser is assuming you are not logged in.


Also make sure the title of model that is shown on top is same as the one that you provided (new name). You will not be allowed to change settings on original model.

Seems like some cache problem. Are you on Chrome?

Oh. Sorry. We dont support IE. Do you have another browser?

Perfect. Could you please use that.

Firefox and Chrome are best suported browsers.

This comment was hidden by Mukul (history)
Mukul (talkcontribs)


Can you send me literature reference that you are pointing to?

Also please go to "Collaborate" tab and sahre your model with support@kogence.com and make support an admin user.

I will take a look. Thanks.

Falaye75 (talkcontribs)


I read it some years ago and my lecture also said that we can use ibrav 0 for silicon band structure and still getting the same structure with that of ibav 2. I just did it but I got different band structures, however I did not know where the error emanated from that is why I posted it here for you to help

Mukul (talkcontribs)

@Falaye75, OK. Please create 2 different models on kogence for 2 cases. Run them o kogence. Make sure they are showing different results. Then share both those models using "Collaborate" tab with support@kogence.com and make support an admin user.

I will take a look. thanks.

Falaye75 (talkcontribs)


I do not know how to do that

Mukul (talkcontribs)

@Falaye75, please look at demo video on front page:


Then look at step-by-step guide here:

Category:Quantum Espresso

Falaye75 (talkcontribs)


I watched the video and some other things yet I could not get what I needed. Please

what is wrong with my input files for ibrav 0 both scf and band?

What makes ibrav 0 structure differ from ibrav 2 structure?

Ibrav 0 gives direct band gap while ibrav 2 gives indirect band gap. It is kwon that silicon has indirect band gap. What is responsible for this disparity?

You can try and run the program to know what I am talking about.


ShinhyukChoi (talkcontribs)

I have a problem to connect to visualizer

it says that it is unable to connect to visualize

yes, i did

simulation has started and it says ' the visualizer is live now'

Centaure99 (talkcontribs)

What error are you seeing?

Just so I understand situation. Did you first login and then created a new model and then executed it right?

Centaure99 (talkcontribs)

@ShinhyukChoi, can you try using one more time?

Let us know if you are still facing problems.

KogenceSupport (talkcontribs)

@ShinhyukChoi, Is visualizer working for you now?

Hadier2abdealziz (talkcontribs)

how to open simualtor

Mukul (talkcontribs)


What are you trying to do? Which simulator are you trying to use?

Kogence platform is organized around "models". Easiest way to get started is to find an existing model that uses the simulator you are interested in. Then make a personal copy and execute that model.

HadeerAbdelaziz (talkcontribs)

Plasmonic nano wire

I do as you mention but run and visualize are not enabled

I use Lumerical FDTD simulator

KogenceSupport (talkcontribs)


Commercial licensed software are available under Serviced Team Plans.

Please sign up for those first and then contact us for configuring license for you.

SaranyaNarayanan (talkcontribs)


I am using MPB . But i am facing a problem in converting .h5 file to .v5d. I have installed h5utils and downloaded Vis5d, but could not install it . Can anyone help?

Mukul (talkcontribs)


Both software are already installed on Kogence. Just login and copy one of the existing models.

That is easiest way to get started. Let us know if you have any further questions.

Piu (talkcontribs)

where is Spin density map file for quantum espresso?

Mukul (talkcontribs)


There are several example models available on kogence platform. Here is an example:


Look under the "Files" tab.

Let me know if you have any further questions?

Shaban (talkcontribs)

./ph.sh: 17: .: Can't open ../../../environment_variables

Mukul (talkcontribs)


Can you give some context? What are you trying to do? Which simulator are you using? Send us the link to the model you are working on. If you need us to look at it then please go to collaborate tab and add support@kogence.com as a collaborator.

Shaban (talkcontribs)

Thank you for your replying

I am try to compute phonon using quantum espresso as a simulator and using phonon example as a model


Mukul (talkcontribs)


Use following command for sourcing environment variables:

. $ENV_VAR_DIR/environment_variables

Comment out following line in you *.sh input file

#. ../../../environment_variables

Here is a working phonon example on Kogence

Quantum Espresso Phonon Example

Masoudrahbar (talkcontribs)


thanks for your help.

i just dont know how to add files for example my input files or pseudopotentials

I cant see the + sign in files tab.there is just a folder sign in the fourth level



thank you

sorry it seems my connection has a problem. i am checking it right know

No i haven't got it yet.

ok i will send

I just sent

i am at the same page but i have no + sign

i sent a screen shot to your email

exactly. Thanks a lot

I ran the same example program and it started running and then said the visualization is live but when I pressed the visualize button after a while it said Kogence has encountered a script error

this error massage is shown"Unable to connect to visualizer please contact Kogence admin"

can it be because of the slow connection?

but it is running the simulation i think. Refresh it?


now the stop button turned into Run and the visualize became inactive.

it seems everything is done.the following is the last line:

cleaning /tmp/qEspresso-eAYzxxqW1KGsB6T2hzMPHIjUAuIdiufL... /tmp/user107/jobT186: done

the scf is done but this is written above the scf output file. what does it mean?

A high-performance Open MPI point-to-point messaging module was unable to find any relevant network interfaces: Module: OpenFabrics (openib) Host: ip-172-30-0-211 Another transport will be used instead, although this may result in lower performance.

Thank you. just the last question.How can I use more cores in my simulations?

Sure. This is really great. I don't know how to express my thanks to all who contributed to this wonderful project.

Mukul (talkcontribs)

Easiest way to get started is to "Copy" an existing example.

This will create copies of "pseudo" directory and a "run_example.sh" files for you in your own copy.

Then you will click "Files" tab on the top toolbar (third level, towards left side)

Thisn show you a fourth level of toolbar towards left side. There you will click the "+" button to add new files or directories.

Also, if you double click on the run_example.sh, that file would open in a code editor.

You can edit this file to add your own *.in content. Look for a line that says something like: cat > *.in << EOF. This is where *.in file is getting created. You can copy paste your own *.in here. Just be careful not to change the file path for pseudo etc. Leave them as it is.

Are you logged-in?

do you have a gmail ID? we can do a hangout and a screen share.

ok. I will send you an hangout invite.

just sent you a hangout invite

did you get it?

ok, no problem.

why dont you send me an invite at

You should see something like this. See the "+" button in white background in fourth level.

Do you see something like this or not ?

I got an email from you but that is not a hangout invite.

I see. Because you have not yet "Copy" the model.

You are not allowed to change somebody else's model until you make a copy.

First click the "Copy" button and save the model as your own copy.

Does that help?

I am happy I could help. Let me know if there is anything else. I am online.

can you refresh your browser?

that will not break. simulation continues to run even if you close the browser.

that means simulation had already stopped. you can go to "Files" tab. and then double click on titusi_output file to see if any errors happened.

so all your results should be in the results directory.

you can check to make sure everything ran as expected.

this is just a technical issue. its a bug in openIB (open version of infiniband) message reporting. openMPI does get used. Dont worry about that. infiniband is proprietory.

openib is an alternative to infiniband.

Click on the "Settings" button. This will open two sub-tabs on fourth level. One for "Machine" and other for "Software". In the machine sub-tab, you can select any machine you like.

It costs us money, so use judiciously! Feel free to use big machine if you really need it.

You are welcome. I am happy that you find it useful.

Mukul (talkcontribs)

@Masoudrahbar, are your problems resolved?

Surjendu (talkcontribs)

How ca n I run program spacegroup in ELK packages?

Mukul (talkcontribs)

@Surjendu were you able to use Elk? If not, please get in touch with support@kogence.com.

Xzhang (talkcontribs)

I am trying to run a Lumerical FDTD simulation. After I click "Run", it shows an error message: "Simulation was submitted... RunJob: Error encountered while trying to run simulation: Software commands are not set."

Could you please help solve this problem? Thanks.

I cannot see Lumerical in the software drop down menu. In addition, do I need to provide a license in order to use Lumerical here? I still did no figure out how to run a simulation on your platform...

It seems that the simulation already started, but I don't know how to visualize the status? I tried to click "Visualize" but the screen is black and it shows error message as shown in the photo.

BTW, I checked the machine details. It shows 2 CPUs, 3.75 GiB Memory. I think this is not enough. How can I have more CPUs and Memories?

Centaure99 (talkcontribs)

You need to select Lumerical from Settings->Software dropdown menu.

You will also need to provide the input file name in the empty textbox.

It would be easiest if you "Copy" an existing Lumerical model to just get started. You can then modify the model.

Are you able to run simulation now?

Yes, you will need to be on paid account to get access to commercial software. Please see our pricing page. I am sorry I Did not realize this before.

You can change machine settings by picking different machine from a dropdown menu. You will first need to make a "Copy" before doing any of these things.

Can you report with Visualizer the error on our Forum page? Our engineer will solve it within 24hours.

Pls put that picture there as well.

Mukul (talkcontribs)

@Xzhang, were you able to run Lumerical simulations? Please get in touch with support@kogence.com. We can help you get started.

DILIP (talkcontribs)


I am a 2nd year Ph.D student and my area od research is Molecular Dynamics and Simulations of Amino-acids in co-solvents.

So is there any thing related to my area of research..??

I am using GROMACS software to perform the simulations

Mukul (talkcontribs)

@DILIP, please check Software Library. There are many simulation software available on Kogence in that area.

Shobhit (talkcontribs)

how to visualize


we are trying to simulate mnist_conv_layer model using tensorflow

but dont know how to visulaize

Mukul (talkcontribs)

@Shobhit, what problem are you facing?